Fixing WordPress update issue for Mac localhost

Today I was trying to put in some work on my custom theme when I noticed that a few of my plugins were out-of-date. I proceeded to use the auto update feature and kept getting a write permission error during the update process. After some searching I found this great little tidbit that helped fix my issue. Go to the root of your WordPress site and run the following in Terminal:
chmod -R go+w *

You may have issues with permissions when trying to upload, import, etc. You can correct this by doing a chmod on your sites folder and subfolders.

From the terminal navigate to your sites folder and run something like the following…

chmod -R go+w *

This will grant group and others write permissions. If you need higher local security, then feel free to grant permissions by a more restrictive method.

This information was gathered from several sources. If you have problems or need additional information, I would reference my sources for this article. Please post additional recommendations and issues in the forum comments associated with this article.

http://www.angry-fly.com/index.cfm/2007/10/26/Fix-for-MySQL-on-Leopard
http://warker.com/2006/09/16/wordpress-os-x-install-tips/
http://remysharp.com/2007/10/27/lamp-in-leopard-osx-105-php5-and-apache-22/

[via tech-recipes]

Date
January 20, 2011
Time
3:25 pm
Category
Uncategorized
Tags
Tags: ,